Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 11, 2026 - 01:00 UTC
Update
Key highlights of the release:
- Device management modernization, including multi-order Amazon fulfillment.
- CareSimple Direct+ Blood Pressure Monitor : Upper-arm blood pressure monitor with one-button operation, wide-range cuff included (22–42 cm / 8.6–16.5 in) with optional small (16–24 cm / 6.3–9.4 in) and large (31–45 cm / 12.2–17.7 in) cuffs, TriCheck™ automated triple-measurement averaging, cuff-fit and movement detection, built-in AFib and irregular heartbeat (IHB) detection, and 90-reading memory with AM/PM averages.
Posted Jun 09, 2026 - 14:52 UTC
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Jun 09, 2026 - 14:22 UTC
This scheduled maintenance affected: CareSimple USA (Care Manager Portal, Observations API, Virtual Visit API, Messaging API, Other APIs) and CareSimple Canada (Care Manager Portal, Observations API, Virtual Visit API, Messaging API, Other APIs).