BodyTrace Device Transmission Outage

Incident Report for CareSimple Service

Resolved

This incident has been resolved.
Posted May 09, 2026 - 19:31 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 09, 2026 - 14:35 UTC

Investigating

Impact:
All standard BodyTrace Blood Pressure monitors (BT106) and Scales (BT006 & BT007) are currently not transmitting readings. This is due to an ongoing outage on the BodyTrace infrastructure.

Affected Devices:
• BT106 — Blood Pressure Monitor
• BT006 — Scale
• BT007 — Scale

Current Actions:
• We've identified the root cause of the issue.
• Actively collaborating with BodyTrace to resolve the issue

We will continue to provide updates as more information becomes available.
Posted May 09, 2026 - 14:35 UTC
This incident affected: CareSimple Cellular Devices (Cellular Body Scale (max 440 lbs), Cellular Blood Pressure Monitor).