CareSimple General Platform Update 25.5

Scheduled for Sep 25, 02:00 - 03:00 UTC

Update

Update 25.5 is being re-schedule next week
Posted Sep 19, 2025 - 01:06 UTC

Update

Platform Update 25.5 is being cancelled
Posted Sep 19, 2025 - 01:03 UTC

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted Sep 16, 2025 - 19:37 UTC
This scheduled maintenance affects: CareSimple USA (Care Manager Portal, Observations API, Virtual Visit API, Messaging API, Other APIs) and CareSimple Canada (Care Manager Portal, Observations API, Virtual Visit API, Messaging API, Other APIs).