Partial Outage - Transmission Failure from SmartMeter Devices

Incident Report for CareSimple Service

Resolved

The issue has now been resolved, it may take up to 24 hours from the onset of the outage for all transmissions to fully resume.
Posted Apr 16, 2026 - 18:55 UTC

Monitoring

We are currently experiencing transmission failures for measurements from SmartMeter devices starting 4/16 7:00 PM GMT. No device readings have been lost. Devices from other manufacturers are being processed as usual. Our team is actively monitoring the issue and will provide an update once it is resolved.

Affected devices:

* iGlucose Essential (Glucometer)
* iBloodPressure Classic (XL BP)
* iScale (XL Scale)
* iPulseOx (Pulse Ox)
Posted Apr 16, 2026 - 18:28 UTC
This incident affected: CareSimple Cellular Devices (Cellular Body Scale (max 440 lbs), Cellular Blood Pressure Monitor, Cellular Blood Glucose Monitor, Cellular Pulse Oximeter, Cellular Body Scale (max 551 lbs)).